[RFC PATCH v2 7/7] arm64: dts: amlogic: t7: khadas-vim4: enable the ethernet port
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Thu Oct 8 01:26:56 PDT 2026
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] dts: magic number used for GPIOH_6 interrupt instead of macro
--
commit f585da8dc95da5050c5f6a8bd4b1962e662ae547
Author: Lucas Tanure <tanure at linux.com>
arm64: dts: amlogic: t7: khadas-vim4: enable the ethernet port
This commit enables the gigabit ethernet controller on the Khadas VIM4 board,
configuring it to communicate with the external Realtek RTL8211F PHY over
RGMII. It also configures the RGMII delays and sets up the PHY interrupt
wiring.
> diff --git a/arch/arm64/boot/dts/amlogic/amlogic-t7-a311d2-khadas-vim4.dts b/arch/arm64/boot/dts/amlogic/amlogic-t7-a311d2-khadas-vim4.dts
> index 0fa83362b4179..4a2b0b5636559 100644
> --- a/arch/arm64/boot/dts/amlogic/amlogic-t7-a311d2-khadas-vim4.dts
> +++ b/arch/arm64/boot/dts/amlogic/amlogic-t7-a311d2-khadas-vim4.dts
[ ... ]
> @@ -256,6 +257,27 @@ xtal: xtal-clk {
> };
> };
[ ... ]
> +&ext_mdio {
> + external_phy: ethernet-phy at 0 {
> + /* Realtek RTL8211FD-CG */
> + reg = <0>;
> + max-speed = <1000>;
> +
> + interrupt-parent = <&gpio_intc>;
> + /* RGMII_INT on GPIOH_6 */
> + interrupts = <154 IRQ_TYPE_LEVEL_LOW>;
[Severity: Low]
Is there a reason to use the magic number 154 here instead of the predefined
GPIOH_6 macro from dt-bindings/gpio/amlogic,t7-periphs-pinctrl.h? Using the
macro directly might improve maintainability and readability.
> + };
> +};
> +
--
Sashiko AI review · https://sashiko.dev/#/patchset/20261007082627.63807-1-tanure@linux.com?part=7
More information about the linux-amlogic
mailing list