[PATCH v2 11/11] lib/bitmap-str: get rid of cpumap_print_to_pagebuf()

sashiko-bot at kernel.org sashiko-bot at kernel.org
Thu Jul 2 08:58:30 PDT 2026


Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The function `cpumap_print_to_pagebuf()` is deleted but still called in `drivers/firmware/psci/psci_checker.c`, causing a build failure for ARM configurations.
--

commit 905d23faa26c3dcaccb88eda3b8626258147c495
Author: Yury Norov <ynorov at nvidia.com>

lib/bitmap-str: get rid of cpumap_print_to_pagebuf()

This commit removes cpumap_print_to_pagebuf(), stating that all users of the
function have been switched to alternatives.

> diff --git a/include/linux/cpumask.h b/include/linux/cpumask.h
> --- a/include/linux/cpumask.h
> +++ b/include/linux/cpumask.h

[ ... ]

> @@ -1315,24 +1314,6 @@ static __always_inline bool cpu_dying(unsigned int cpu)
>  }
>  #endif /* NR_CPUS > BITS_PER_LONG */
>  
> -/**
> - * cpumap_print_to_pagebuf  - copies the cpumask into the buffer either
> - *	as comma-separated list of cpus or hex values of cpumask
> - * @list: indicates whether the cpumap must be list
> - * @mask: the cpumask to copy
> - * @buf: the buffer to copy into
> - *
> - * Return: the length of the (null-terminated) @buf string, zero if
> - * nothing is copied.
> - */
> -static __always_inline ssize_t
> -cpumap_print_to_pagebuf(bool list, char *buf, const struct cpumask *mask)
> -{

[Severity: Low]
Will this removal cause a build break for ARM configurations?

It appears there is still at least one remaining caller of this function
that was not migrated in drivers/firmware/psci/psci_checker.c:

drivers/firmware/psci/psci_checker.c:hotplug_tests() {
    ...
        ssize_t len = cpumap_print_to_pagebuf(true, page_buf,
                                              cpu_groups[i]);
    ...
}

Does this remaining callsite need to be updated to an alternative before
dropping the function?

> -	/* Opencode offset_in_page(buf) to not include linux/mm.h */
> -	return scnprintf(buf, PAGE_SIZE - ((unsigned long)buf & ~PAGE_MASK),
> -			 list ? "%*pbl\n" : "%*pb\n", cpumask_pr_args(mask));
> -}

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260702154725.185376-1-ynorov@nvidia.com?part=11



More information about the linux-amlogic mailing list