[PATCH] soc: amlogic: meson-pwrc: Hold reference returned by of_get_parent()

Liang He windhl at 126.com
Mon Jul 25 18:17:21 PDT 2022


At 2022-07-26 03:46:30, "Martin Blumenstingl" <martin.blumenstingl at googlemail.com> wrote:
>Hello,
>
>thank you for your patch!
>
>On Tue, Jul 5, 2022 at 4:20 AM Liang He <windhl at 126.com> wrote:
>[...]
>> +       struct device_node *np;
>>
>>         int i, ret;
>>
>>         match = of_device_get_match_data(&pdev->dev);
>> @@ -495,7 +496,9 @@ static int meson_ee_pwrc_probe(struct platform_device *pdev)
>>
>>         pwrc->xlate.num_domains = match->count;
>>
>> -       regmap_hhi = syscon_node_to_regmap(of_get_parent(pdev->dev.of_node));
>> +       np = of_get_parent(pdev->dev.of_node);
>> +       regmap_hhi = syscon_node_to_regmap(np);
>This works but I had to read the code twice because I thought the
>wrong struct device_node was used.
>Other drivers typically use "np" for whatever the code section
>currently refers to. In this case the code section is about the power
>controller, so I thought that "np" was the same as
>"pdev->dev.of_node".
>
>I think the code would be easier to understand and the likelihood of
>someone making the same mistake as I did if you could rename "np" to
>"parent_np" (just like you have done in your other patches).
>
>[...]
>> +       struct device_node *np;

>same as above, I suggest renaming this to parent_np.


Hi, Martin,


I notice the declarations keep the reverse Christmas tree order, 
should I keep that order as the  'parent_np' will become longer than 'np'.


Thanks,
Liang


More information about the linux-amlogic mailing list