[PATCH 2/5] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64 in linux/setbits.h
clabbe at baylibre.com
Mon Sep 10 11:53:25 PDT 2018
On Mon, Sep 10, 2018 at 07:22:04AM +0200, Christophe LEROY wrote:
> Le 07/09/2018 à 21:41, Corentin Labbe a écrit :
> > This patch adds setbits32/clrbits32/clrsetbits32 and
> > setbits64/clrbits64/clrsetbits64 in linux/setbits.h header.
> So you changed the name of setbits32() ... to setbits32_be() and now you
> are adding new functions called setbits32() ... which do something
> different ?
> What will happen if any file has been forgotten during the conversion,
> or if anybody has outoftree drivers and missed this change ?
> They will silently successfully compile without any error or warning,
> and the result will be crap buggy.
> And why would it be more legitim to have setbits32() be implicitely LE
> instead of implicitely BE ?
> I really think those new functions should be called something like
> setbits_le32() ...
I believed that writel/readl was endian agnostic so it explain my mistake.
I will use xxxbits_le32 as you requests.
More information about the linux-amlogic