[PATCH 1/2] i2c: add Amlogic Meson driver

Simon Glass sjg at chromium.org
Mon Nov 27 09:10:05 PST 2017


Hi Benjamin,

On 26 November 2017 at 09:49, Beniamino Galvani <b.galvani at gmail.com> wrote:
> On Mon, Nov 20, 2017 at 08:36:34AM -0700, Simon Glass wrote:
>> Hi Benjamin,
>>
>> On 29 October 2017 at 03:09, Beniamino Galvani <b.galvani at gmail.com> wrote:
>> >
>> > Add a driver for the I2C controller available on Amlogic Meson SoCs.
>> >
>> > Signed-off-by: Beniamino Galvani <b.galvani at gmail.com>
>> > ---
>> >  arch/arm/include/asm/arch-meson/i2c.h |  11 ++
>> >  drivers/i2c/Kconfig                   |   6 +
>> >  drivers/i2c/Makefile                  |   1 +
>> >  drivers/i2c/meson_i2c.c               | 263 ++++++++++++++++++++++++++++++++++
>> >  4 files changed, 281 insertions(+)
>> >  create mode 100644 arch/arm/include/asm/arch-meson/i2c.h
>> >  create mode 100644 drivers/i2c/meson_i2c.c
>>
>> Reviewed-by: Simon Glass <sjg at chromium.org>
>>
>> But please look at the comments below.
>
> Hi Simon,
>
> I addressed your suggestions in a follow-up series, thanks.
>
>> > +U_BOOT_DRIVER(i2c_meson) = {
>> > +       .name = "i2c_meson",
>> > +       .id   = UCLASS_I2C,
>> > +       .of_match = meson_i2c_ids,
>> > +       .probe = meson_i2c_probe,
>> > +       .priv_auto_alloc_size = sizeof(struct meson_i2c),
>>
>> I think meson_i2c_priv might be a better name since it indicates that
>> it is driver-private data. But if you prefer the shorter name, that's
>> fine with me.
>
> I think I slightly prefer it, but both would be fine. Since the patch
> is already applied, let's keep it as is?

OK.

Regards,
Simon



More information about the linux-amlogic mailing list