rmmod libertas_sdio and reinsert causes problems with firmwareupload.

Jonathan Cameron jic23 at cam.ac.uk
Thu Sep 4 05:57:04 EDT 2008

Dan Williams wrote:
> On Wed, 2008-09-03 at 15:58 +0200, Pierre Ossman wrote:
>> On Wed, 03 Sep 2008 14:47:04 +0100
>> Jonathan Cameron <jic23 at cam.ac.uk> wrote:
>>> Any thoughts?
>> Have you tried using just disable/enable function? It might reset the
>> device the same way you're trying to do with the command.
> I tried two things:
> 1) sending CMD_802_11_RESET and then disable/enable the function
>     - This froze the card as described
>     - On re-enabling the function, the stack couldn't talk to the card
> 2) Only disable/enable the function
>     - This didn't really do anything at all
Well at least it's consistent I suppose.

Anyhow, Marvell's driver actually sends the reset command as part of its
tearing down of the card.  Has anyone got a setup with that driver running
on it that can verify it works and doesn't freeze as Dan and I have
both experienced?



More information about the libertas-dev mailing list