XO -> XO ping problem

Javier Cardona javier at cozybit.com
Thu Jun 28 01:53:26 EDT 2007


Thanks for the detailed bug report.  Can the xo's ping each other over
the mesh (i.e. assign an IP to the msh0 interface, and ping -I msh0)?
What AP are you using?.  If the answer to the first question is yes
and the AP being used does lazy-WDS (such as the WRT54G), then I have
a good theory.  And the good news would be that the problem is solved
by the new mesh data frame format that was released last week.  But
let's wait until we try it in the office.


On 6/27/07, Dan Williams <dcbw at redhat.com> wrote:
> Javier,
> We're observing an interesting problem here, replicated in at least 3
> different locations (Waltham (me), Toronto (tamtam), Arlington
> (dilinger)) on a bunch of different builds (406.x, 432, 451) with
> different hardware (B1, B2, B3) and different firmware (5.220.10.p5,
> 5.220.11.p5).  In all 3 locations, nothing is doing mesh networking at
> all.
> The problem is that when connected in infrastructure mode, two XOs
> cannot ping each _other_, but other normal laptops connected to the same
> AP can ping each XO, and the XO can both ping the normal laptop and
> external sites like google.
> For my investigation of this problem, I turned off NetworkManager
> completely and booted up in runlevel 3.
> On both laptops I have, I did:
> chkconfig --level 345 NetworkManager off
> chkconfig --level 345 dhcdbd off
> chkconfig --level 345 network off
> nano /etc/inittab (set runlevel 3 as default)
> <reboot>
> iwconfig eth0 essid foobar key <blah> mode managed
> dhclient -1 eth0
> and then tried to ping each other XO from the other, and to ping google,
> and to ping my ThinkPad T42.  The XOs always failed to ping each other,
> but could both ping google and my T42.
> Digging further into the issue, I found via wireshark/ethereal on my
> thinkpad that I can see the ARP request from XO1 -> XO2, but XO2 never
> sends an ARP reply back (as seen from wireshark).  Turning on RX & TX
> debugging in the driver on the XO2 shows the "SendSinglePacket succeeds"
> message for (apparently) each ARP request XO2 receives, which I
> interpret to mean that XO2 is actually trying to send the ARP reply, but
> that the reply gets lost between the host_to_card() function and the
> radio.  I can actually try to get the hexdump of the outgoing tx packets
> if that would help.
> However, running tcpdump on both machines has interesting results.  The
> pinging XO1 shows the pings in the dump, but the dump from the XO2 being
> pinged shows only LLC frames, and no ICMP frames.  tcpdump isn't getting
> any pings.  If you want the tcpdumps I can send you a link.
> Thoughts?  Can you try to replicate with, say, build 451 and debug the
> issue as well?
> Thanks,
> Dan

Javier Cardona
cozybit Inc.
p 415 974 6770
f 415 974 6771
c 415 630 0627
e javier at cozybit.com

More information about the libertas-dev mailing list