[LEDE-DEV] Compile issue with e2fsprogs due to libblkid dependency

Jesper Dangaard Brouer brouer at redhat.com
Sat Oct 7 02:57:56 PDT 2017

In latest LEDE/source git tree (at commit b9c31c44d71) the package
'e2fsprogs' have seems to have compile issues (package/utils/e2fsprogs/).

Compiling package separate::

 make package/e2fsprogs/compile V=s
 Package e2fsprogs is missing dependencies for the following libraries:

This seems related to commit::

 commit 5b1660a5387bfe7e522945b7318dd9b0f8ac307d
 Author: Daniel Engberg <daniel.engberg.lists at pyret.net>
 Date:   Fri Sep 8 00:44:26 2017 +0200

    utils/e2fsprogs: Update to 1.43.6
    Update e2fsprogs to 1.43.6
    Disable compilation of fuse2fs (we don't package it)
    Disable thread support (only affects fuse2fs)
    Enable linking with libblkid instead of using private (included) version.
    The libblkid is ~210KBytes in size, but with using the shared library
    the binaries are ~25KBytes smaller. This also brings it in sync with
    most other Linux distributions.
    Signed-off-by: Daniel Engberg <daniel.engberg.lists at pyret.net>

I don't know that the proper fix is, but reverting this commit solved
my compile blocker for e2fsprogs.  (openvswitch also failed, but I
just disabled it).

My .config does contain libblkid but as a module::

 grep libblkid .config

I also tried to select CONFIG_PACKAGE_libblkid=y but didn't help.

More strange, the package/utils/e2fsprogs/Makefile have configure
options to disable libblkid, but perhaps this is a trick to not link
against a static lib? ::

        --disable-testio-debug \
        --enable-elf-shlibs     \
        --disable-libuuid       \
        --disable-libblkid      \

Try to compile libblkid explicitly fails::

 $ make package/libblkid/compile V=s
 make[1]: Entering directory '/home/jbrouer/git/LEDE/source'
 make[1]: *** No rule to make target 'package/libblkid/compile'.  Stop.
 make[1]: Leaving directory '/home/jbrouer/git/LEDE/source'
 /home/jbrouer/git/LEDE/source/include/toplevel.mk:207: recipe for target 'package/libblkid/compile' failed
 make: *** [package/libblkid/compile] Error 2

It seems to be part of package/utils/util-linux/Makefile

 $ make package/util-linux/compile V=s
 make[2]: Entering directory '~/git/LEDE/source/package/utils/util-linux'
echo "libblkid" >> ~/git/LEDE/source/staging_dir/target-mips_24kc_musl/pkginfo/util-linux.default.install
echo "libuuid" >> ~/git/LEDE/source/staging_dir/target-mips_24kc_musl/pkginfo/util-linux.default.install

Best regards,
  Jesper Dangaard Brouer
  MSc.CS, Principal Kernel Engineer at Red Hat
  LinkedIn: http://www.linkedin.com/in/brouer

More information about the Lede-dev mailing list