[LEDE-DEV] dnsmasq

e9hack e9hack at gmail.com
Fri Jul 29 09:48:43 PDT 2016


-- /etc/config/network --

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde9:bdbb:ce7c::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ifname 'eth1.1 tap0 tun2'
	option ipaddr '192.168.103.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ip6hint '5a5a'

config interface 'guest1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.1.0.1'
	option netmask '255.255.0.0'

config interface 'guest2'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.2.0.1'
	option netmask '255.255.0.0'

config alias
	option interface 'lan'
	option proto 'static'
	option ip6addr 'fec0:0:0:ffff:0:0:0:1/64'

config alias
	option interface 'lan'
	option proto 'static'
	option ip6addr 'fec0:0:0:ffff:0:0:0:2/64'

config interface 'wan'
	option ifname 'eth0.7'
	option proto 'pppoe'
	option username '0000000000000000000000000000 at t-online.de'
	option password 'ZZZZZZZZ'
	option keepalive '10 5'

config 'interface' 'vlan8'
	option 'ifname' 'eth0.8'
	option 'proto' 'dhcp'

config interface 'modem'
	option ifname 'eth0.2'
	option proto 'static'
	option ipaddr '192.168.1.80'
	option netmask '255.255.255.0'
	option peerdns '0'

config interface 'wan_6'
	option ifname '@wan'
	option proto 'dhcpv6'
	option reqprefix 'auto'
	option reqaddress 'force'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 0t'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '1t 6t'

config switch_vlan
	option device 'switch0'
	option vlan '8'
	option ports '1t 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '5 0t'

config interface 'phone'
	option ifname 'eth1.3'
	option proto 'static'
	option ipaddr '192.168.200.1'
	option netmask '255.255.255.0'
	option ipv6 '0'

config interface 'vpn'
	option proto 'none'
	option ifname 'tun1'

config interface 'tor'
	option type 'bridge'
	option proto 'static'
	option ipaddr '172.16.1.1'
	option netmask '255.255.0.0'
	option ipv6 '0'
----

-- /etc/config/dhcp (host, mac and domain entries are removed) --

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	list notinterface 'tap0'
	list notinterface 'eth0'
	list notinterface 'eth1'
	list notinterface 'eth1.1'
	list notinterface 'wan'
	list notinterface 'wan6'
	list interface 'lan'
	list interface 'phone'
	list interface 'guest1'
	list interface 'guest2'
	list interface 'tor'
	option cachesize '500'
	option dnssec '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '100'
	option leasetime '48h'
	option ra 'server'
	option ra_preference 'high'
	list dns 'fec0:0:0:ffff::1'
	list dns 'fec0:0:0:ffff::2'
	option ndp 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config dhcp 'vlan8'
	option interface 'vlan8'
	option ignore '1'

config dhcp 'guest1'
	option interface 'guest1'
	option start '100'
	option limit '100'
	option leasetime '48h'

config dhcp 'guest2'
	option interface 'guest2'
	option start '100'
	option limit '100'
	option leasetime '48h'

config dhcp 'phone'
	option interface 'phone'
	option start '100'
	option limit '100'
	option leasetime '48h'

config dhcp 'tor'
	option interface 'tor'
	option start '100'
	option limit '100'
	option leasetime '2h'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
----

-- /etc/config/dhcp.dnsmasq (dhcp-host and host-record entries are removed) --

dhcp-option=option6:dns-server,[fec0:0:0:ffff:0:0:0:1]
dhcp-range=lan,fec0:0:0:ffff:0:0:ffff:100,fec0:0:0:ffff:0:0:ffff:ffff,48h
rebind-localhost-ok
bind-dynamic
------

dhcp.dnsmasq is include via /etc/dnsmasq.conf. Configuration isn't simple.

Regards,
Hartmut

Am 29.07.2016 um 18:09 schrieb Felix Fietkau:
> On 2016-07-29 17:43, e9hack wrote:
>> Hi,
>>
>> something in this updates is wrong:
>> dnsmasq: replace the iface hotplug script with a procd trigger
>> dnsmasq: make the check for existing DHCP servers more reliable
>> dnsmasq: write atomic config file
>>
>> In /var/etc/dnsmasq.conf the entry
>>
>> interface=br-lan
>>
>> is set as
>>
>> interface=eth1.1 tap0  tun2
>>
>> and name resolution doesn't work.
> Please show me your /etc/config/network and /etc/config/dhcp.
> I can't reproduce this issue.




More information about the Lede-dev mailing list