[source] hostapd: fix reload frequency change patch

LEDE Commits lede-commits at lists.infradead.org
Thu Dec 14 09:44:03 PST 2017


jow pushed a commit to source.git, branch lede-17.01:
https://git.lede-project.org/6b9eb0c73a7ced5091b7ab8011b9788ba23d5b79

commit 6b9eb0c73a7ced5091b7ab8011b9788ba23d5b79
Author: Abhilash Tuse <Abhilash.Tuse at imgtec.com>
AuthorDate: Thu Mar 23 11:34:32 2017 +0530

    hostapd: fix reload frequency change patch
    
    When sta is configured, hostapd receives 'stop' and 'update' command from
    wpa_supplicant. In the update command, hostapd gets sta parameters with
    which it configures ap.
    
    Problem is, with the default wireless configuration:
    mode:11g freq:2.4GHz channel:1
    If sta is connected to 5GHz network, then ap does not work. Ideally with
    340-reload_freq_change.patch hostapd should reload the frequency changes
    and start ap in 5GHz, but ap becomes invisible in the network.
    
    This issue can be reproduced with following /etc/config/wireless:
    config wifi-device  radio0
            option type     mac80211
            option channel  1
            option hwmode   11g
            option path     'virtual/uccp420/uccwlan'
            option htmode   'none'
    
    config wifi-iface 'ap'
            option device 'radio0'
            option encryption 'none'
            option mode 'ap'
            option network 'ap'
            option ssid 'MyTestNet'
            option encryption none
    
    config wifi-iface 'sta'
           option device radio0
           option network sta
           option mode sta
           option ssid TestNet-5G
           option encryption psk2
           option key 12345
    
    This change updates current_mode structure based on configured hw_mode
    received from wpa_supplicant. Also prepare rates table after frequency
    selection.
    
    Signed-off-by: Abhilash Tuse <Abhilash.Tuse at imgtec.com>
    Signed-off-by: Felix Fietkau <nbd at nbd.name> [cleanup, patch refresh]
    (cherry picked from commit 41feba8c4aa33ca3c6fa7c1a6c3224aae02440a7)
---
 .../hostapd/patches/340-reload_freq_change.patch   | 29 ++++++++++++++++++++--
 .../hostapd/patches/600-ubus_support.patch         | 10 ++++----
 2 files changed, 32 insertions(+), 7 deletions(-)

diff --git a/package/network/services/hostapd/patches/340-reload_freq_change.patch b/package/network/services/hostapd/patches/340-reload_freq_change.patch
index 086ade9..0dcd7c9 100644
--- a/package/network/services/hostapd/patches/340-reload_freq_change.patch
+++ b/package/network/services/hostapd/patches/340-reload_freq_change.patch
@@ -1,6 +1,6 @@
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -80,6 +80,16 @@ static void hostapd_reload_bss(struct ho
+@@ -80,6 +80,25 @@ static void hostapd_reload_bss(struct ho
  #endif /* CONFIG_NO_RADIUS */
  
  	ssid = &hapd->conf->ssid;
@@ -14,13 +14,38 @@
 +			 hapd->iconf->vht_oper_centr_freq_seg0_idx,
 +			 hapd->iconf->vht_oper_centr_freq_seg1_idx);
 +
++	if (hapd->iface->current_mode) {
++		if (hostapd_prepare_rates(hapd->iface, hapd->iface->current_mode)) {
++			wpa_printf(MSG_ERROR, "Failed to prepare rates table.");
++			hostapd_logger(hapd, NULL, HOSTAPD_MODULE_IEEE80211,
++				       HOSTAPD_LEVEL_WARNING,
++				       "Failed to prepare rates table.");
++		}
++	}
++
  	if (!ssid->wpa_psk_set && ssid->wpa_psk && !ssid->wpa_psk->next &&
  	    ssid->wpa_passphrase_set && ssid->wpa_passphrase) {
  		/*
-@@ -179,21 +189,12 @@ int hostapd_reload_config(struct hostapd
+@@ -158,6 +177,7 @@ int hostapd_reload_config(struct hostapd
+ 	struct hostapd_data *hapd = iface->bss[0];
+ 	struct hostapd_config *newconf, *oldconf;
+ 	size_t j;
++	int i;
+ 
+ 	if (iface->config_fname == NULL) {
+ 		/* Only in-memory config in use - assume it has been updated */
+@@ -179,21 +199,20 @@ int hostapd_reload_config(struct hostapd
  	oldconf = hapd->iconf;
  	iface->conf = newconf;
  
++	for (i = 0; i < iface->num_hw_features; i++) {
++		struct hostapd_hw_modes *mode = &iface->hw_features[i];
++		if (mode->mode == iface->conf->hw_mode) {
++			iface->current_mode = mode;
++			break;
++		}
++	}
++
 +	if (iface->conf->channel)
 +		iface->freq = hostapd_hw_get_freq(hapd, iface->conf->channel);
 +
diff --git a/package/network/services/hostapd/patches/600-ubus_support.patch b/package/network/services/hostapd/patches/600-ubus_support.patch
index 0d9aca9..dd962b4 100644
--- a/package/network/services/hostapd/patches/600-ubus_support.patch
+++ b/package/network/services/hostapd/patches/600-ubus_support.patch
@@ -41,7 +41,7 @@
  		HAPD_IFACE_DISABLED,
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -284,6 +284,7 @@ static void hostapd_free_hapd_data(struc
+@@ -302,6 +302,7 @@ static void hostapd_free_hapd_data(struc
  	hapd->started = 0;
  
  	wpa_printf(MSG_DEBUG, "%s(%s)", __func__, hapd->conf->iface);
@@ -49,7 +49,7 @@
  	iapp_deinit(hapd->iapp);
  	hapd->iapp = NULL;
  	accounting_deinit(hapd);
-@@ -1142,6 +1143,8 @@ static int hostapd_setup_bss(struct host
+@@ -1160,6 +1161,8 @@ static int hostapd_setup_bss(struct host
  	if (hapd->driver && hapd->driver->set_operstate)
  		hapd->driver->set_operstate(hapd->drv_priv, 1);
  
@@ -58,7 +58,7 @@
  	return 0;
  }
  
-@@ -1665,6 +1668,7 @@ static int hostapd_setup_interface_compl
+@@ -1683,6 +1686,7 @@ static int hostapd_setup_interface_compl
  	if (err)
  		goto fail;
  
@@ -66,7 +66,7 @@
  	wpa_printf(MSG_DEBUG, "Completing interface initialization");
  	if (iface->conf->channel) {
  #ifdef NEED_AP_MLME
-@@ -1844,6 +1848,7 @@ dfs_offload:
+@@ -1862,6 +1866,7 @@ dfs_offload:
  
  fail:
  	wpa_printf(MSG_ERROR, "Interface initialization failed");
@@ -74,7 +74,7 @@
  	hostapd_set_state(iface, HAPD_IFACE_DISABLED);
  	wpa_msg(hapd->msg_ctx, MSG_INFO, AP_EVENT_DISABLED);
  #ifdef CONFIG_FST
-@@ -2292,6 +2297,7 @@ void hostapd_interface_deinit_free(struc
+@@ -2310,6 +2315,7 @@ void hostapd_interface_deinit_free(struc
  		   (unsigned int) iface->conf->num_bss);
  	driver = iface->bss[0]->driver;
  	drv_priv = iface->bss[0]->drv_priv;



More information about the lede-commits mailing list