[FS#633] 802.1ad (QinQ) VLANs broken since kernel 4.3 in ramips mt7620

LEDE Bugs lede-bugs at lists.infradead.org
Fri Mar 17 09:10:22 PDT 2017


The following task has a new comment added:

FS#633 - 802.1ad (QinQ) VLANs broken since kernel 4.3 in ramips mt7620
User who did this - rogerpueyo (rogerpueyo)

----------
====Update====
If the MT7620 internal switch is disabled and 802.1ad VLANs are used, the problem persists. For instance:
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config device 'eth0_4'
        option type '8021ad'
        option name 'eth0_4'
        option ifname 'eth0'
        option vid '4'

config interface 'eth0_4_ad'
        option ifname 'eth0_4'
        option auto '1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.11.2'
        option ip6addr 'fd02::dc9f:db4f:a1f6:4:2/125'

causes the same TCP checksum errors.

However, if 802.1q VLANs are used:
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config device 'eth0_4'
        option type '8021q'
        option name 'eth0_4'
        option ifname 'eth0'
        option vid '4'

config interface 'eth0_4_ad'
        option ifname 'eth0_4'
        option auto '1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.11.2'
        option ip6addr 'fd02::dc9f:db4f:a1f6:4:2/125'

TCP checksum offloading works well.

Therefore, I suspect it is the combination of 802.1ad VLANs + TCP checksum offloading what is wrong.
----------

More information can be found at the following URL:
https://bugs.lede-project.org/index.php?do=details&task_id=633#comment2178



More information about the lede-bugs mailing list