[FS#525] Problem with DHCP forwarding / Routed Client with relayd (Pseudobridge)

LEDE Bugs lede-bugs at lists.infradead.org
Thu Feb 16 22:26:31 PST 2017


A new Flyspray task has been opened.  Details are below. 

User who did this - shaarkys (shaarkys) 

Attached to Project - LEDE Project
Summary - Problem with DHCP forwarding / Routed Client with relayd (Pseudobridge)
Task Type - Bug Report
Category - Base system
Status - Unconfirmed
Assigned To - 
Operating System - All
Severity - Low
Priority - Very Low
Reported Version - Trunk
Due in Version - Undecided
Due Date - Undecided
Details - Hi,

my setup is very similar to what is described here - https://wiki.openwrt.org/doc/recipes/relayclient3 (repeater). Any clients trying to get IP address via DHCP from master AP simply get no address. On version LEDE Reboot SNAPSHOT r2028+637-9acd90b / LuCI Master all is fine, on versions LEDE Reboot SNAPSHOT r2028+761-5bcb434 and later it (getting DHCP address) doesn't work.

In syslog I don't see anything suspicions ... any idea where I should take a look please ?
I'm self-compiling firmware myself , using always same config.... (via env)

Confirmed issue on model TP-Link TL-WR841N/ND v8.

Actually although I wrote it's DHCP packet forwarding, I do think the problem is somewhere else.
I also noticed that the packets between or let's say within bridged interface don't flow, eg. on wifi connected client I can't ping second AP (with IP static), but directly on the console it works... 

Is there anything I can test ? I think it's worth to remove this bug from V17 final... **if it's a bug but the same config works on my build from LEDE Reboot SNAPSHOT r2028+637-9acd90b but later builds it don't.**

My config if that would help :

**wireless**

   config wifi-device 'radio0'
    	option type 'mac80211'
    	option hwmode '11g'
    	option path 'pci0000:00/0000:00:00.0'
    	option htmode 'HT40'
    	option noscan '1'
    	option channel '11'
    	option country 'US'
    	option txpower '21'

    config wifi-iface
    	option device 'radio0'
    	option mode 'sta'
    	option key 'password'
    	option network 'wwan'
    	option bssid '64:70:02:A4:E2:12'
    	option wds '1'
    	option encryption 'psk'
    	option ssid 'apwifi'

    config wifi-iface
    	option device 'radio0'
    	option mode 'ap'
    	option network 'lan'
    	option encryption 'psk-mixed'
    	option key 'password'
    	option ssid 'apwifi'
      
**dhcp**

      config dnsmasq
    	option boguspriv '1'
    	option localise_queries '1'
    	option rebind_protection '1'
    	option rebind_localhost '1'
    	option local '/lan/'
    	option domain 'lan'
    	option expandhosts '1'
    	option readethers '1'
    	option leasefile '/tmp/dhcp.leases'
    	option resolvfile '/tmp/resolv.conf.auto'

    config dhcp 'lan'
    	option interface 'lan'
    	option ignore '1'

    config dhcp 'wan'
    	option interface 'wan'
    	option ignore '1'

    config odhcpd 'odhcpd'
    	option maindhcp '0'
    	option leasefile '/tmp/hosts/odhcpd'
    	option leasetrigger '/usr/sbin/odhcpd-update' 
    	
**network**
    	
        config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'

    config globals 'globals'
    	option ula_prefix 'fda6:caad:273f::/48'

    config interface 'lan'
    	option ifname 'eth0'
    	option force_link '1'
    	option type 'bridge'
    	option proto 'static'
    	option netmask '255.255.255.0'
    	option ipaddr '10.11.0.2'
    	option delegate '0'
    	option stp '1'
    	option dns '10.11.0.1 8.8.8.8'
    	option gateway '10.11.0.1'

    config switch
    	option name 'switch0'
    	option reset '1'
    	option enable_vlan '1'

    config switch_vlan
    	option device 'switch0'
    	option vlan '1'
    	option ports '0 1 2 3 4'

    config interface 'wwan'
    	option proto 'dhcp'
    	option delegate '0'

    config interface 'stabridge'
    	option proto 'relay'
    	list network 'lan'
    	list network 'wwan'
    	option ipaddr '10.11.0.90'
    	option delegate '0'
    	
**    	firewall**

config defaults
    	option syn_flood '1'
    	option input 'ACCEPT'
    	option output 'ACCEPT'
    	option forward 'REJECT'

    config zone
    	option name 'lan'
    	option input 'ACCEPT'
    	option output 'ACCEPT'
    	option forward 'ACCEPT'
    	option network 'lan stabridge wwan'

    config zone
    	option name 'wan'
    	option output 'ACCEPT'
    	option masq '1'
    	option mtu_fix '1'
    	option input 'REJECT'
    	option forward 'REJECT'
    	option network 'wan wan6'

    config forwarding
    	option src 'lan'
    	option dest 'wan'

    config rule
    	option name 'Allow-DHCP-Renew'
    	option src 'wan'
    	option proto 'udp'
    	option dest_port '68'
    	option target 'ACCEPT'
    	option family 'ipv4'

    config rule
    	option name 'Allow-Ping'
    	option src 'wan'
    	option proto 'icmp'
    	option icmp_type 'echo-request'
    	option family 'ipv4'
    	option target 'ACCEPT'

    config rule
    	option name 'Allow-DHCPv6'
    	option src 'wan'
    	option proto 'udp'
    	option src_ip 'fe80::/10'
    	option src_port '547'
    	option dest_ip 'fe80::/10'
    	option dest_port '546'
    	option family 'ipv6'
    	option target 'ACCEPT'

    config rule
    	option name 'Allow-ICMPv6-Input'
    	option src 'wan'
    	option proto 'icmp'
    	list icmp_type 'echo-request'
    	list icmp_type 'echo-reply'
    	list icmp_type 'destination-unreachable'
    	list icmp_type 'packet-too-big'
    	list icmp_type 'time-exceeded'
    	list icmp_type 'bad-header'
    	list icmp_type 'unknown-header-type'
    	list icmp_type 'router-solicitation'
    	list icmp_type 'neighbour-solicitation'
    	list icmp_type 'router-advertisement'
    	list icmp_type 'neighbour-advertisement'
    	option limit '1000/sec'
    	option family 'ipv6'
    	option target 'ACCEPT'

    config rule
    	option name 'Allow-ICMPv6-Forward'
    	option src 'wan'
    	option dest '*'
    	option proto 'icmp'
    	list icmp_type 'echo-request'
    	list icmp_type 'echo-reply'
    	list icmp_type 'destination-unreachable'
    	list icmp_type 'packet-too-big'
    	list icmp_type 'time-exceeded'
    	list icmp_type 'bad-header'
    	list icmp_type 'unknown-header-type'
    	option limit '1000/sec'
    	option family 'ipv6'
    	option target 'ACCEPT'

    config include
    	option path '/etc/firewall.user'

    config rule
    	option target 'ACCEPT'
    	option proto 'tcp'
    	option dest_port '80'
    	option name 'Openwrt'
    	option dest_ip '10.11.0.2'
    	option src '*'

    config redirect
    	option target 'DNAT'
    	option dest 'lan'
    	option proto 'tcp'
    	option src_dport '80'
    	option dest_ip '10.11.0.2'
    	option dest_port '80'
    	option name 'Openwrt'
    	option src 'lan'
    	option enabled '0'

    config redirect
    	option target 'DNAT'
    	option dest 'lan'
    	option proto 'tcp'
    	option src_dport '80'
    	option dest_ip '10.11.0.90'
    	option dest_port '80'
    	option name 'Openwrt_90'
    	option src 'lan'
    	option enabled '0'

    config rule
    	option target 'ACCEPT'
    	option proto 'tcp'
    	option dest_port '80'
    	option name 'Openwrt_90'
    	option src '*'
    	option dest_ip '10.11.0.90'

 

More information can be found at the following URL:
https://bugs.lede-project.org/index.php?do=details&task_id=525



More information about the lede-bugs mailing list