[FS#507] network configuration messed up / not usable

LEDE Bugs lede-bugs at lists.infradead.org
Tue Feb 14 02:47:11 PST 2017


The following task has a new comment added:

FS#507 - network configuration messed up / not usable
User who did this - olze (olze)

----------
To get the devices with ifconfig, this config can be used (not tested yet, thanks to jow from irc) :

config interface 'lan1'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
 
config interface 'lan2'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '10.2.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
 
config interface 'lan3'
        option ifname 'eth0.3'
        option proto 'static'
        option ipaddr '10.3.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
 
config interface 'lan4'
        option ifname 'eth0.4'
        option proto 'static'
        option ipaddr '10.4.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
 
config interface 'lan5'
        option ifname 'eth0.5'
        option proto 'static'
        option ipaddr '10.5.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
 
config interface 'lan6'
        option ifname 'eth0.6'
        option proto 'static'
        option ipaddr '10.6.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
 
config interface 'sfp'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '10.7.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
 
config interface 'wan'
        option ifname 'eth2'
        option proto 'dhcp'
 
config interface 'wan6'
        option ifname 'eth2'
        option proto 'dhcpv6'
 
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
 
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '4 5t'
 
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '3 5t'
 
config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '2 5t'
 
config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '1 5t'
 
config switch_vlan
        option device 'switch0'
        option vlan '5'
        option ports '0 5t'
 
config switch_vlan
        option device 'switch0'
        option vlan '6'
        option ports '6 5t'
----------

More information can be found at the following URL:
https://bugs.lede-project.org/index.php?do=details&task_id=507#comment1794



More information about the lede-bugs mailing list