[FS#94] netifd: PPPoE MTU problem

LEDE Bugs lede-bugs at lists.infradead.org
Fri Oct 7 14:22:00 PDT 2016


The following task has a new comment added:

FS#94 - netifd: PPPoE MTU problem
User who did this - Mathias Kresin (mkresin)

----------
I was able to reproduce the issue.


config interface 'wan'
        option ifname 'ptm0.7'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 'auto'

config device 'wan_dev'
        option name 'ptm0'
        option mtu '1508'


results in:


ptm0      Link encap:Ethernet  HWaddr 11:22:33:44:55:66
          UP BROADCAST MULTICAST  MTU:1508  Metric:1

ptm0.7    Link encap:Ethernet  HWaddr 11:22:33:44:55:67  
          UP BROADCAST MULTICAST  MTU:1508  Metric:1


----


config interface 'wan'
        option ifname 'ptm0.7'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 'auto'
        option mtu '1500'

config device 'wan_dev'
        option name 'ptm0'
        option mtu '1508'


results in:


ptm0      Link encap:Ethernet  HWaddr 11:22:33:44:55:67
          UP BROADCAST MULTICAST  MTU:1508  Metric:1

ptm0.7    Link encap:Ethernet  HWaddr 11:22:33:44:55:67
          UP BROADCAST MULTICAST  MTU:1500  Metric:1


----


config interface 'wan'
        option ifname 'ptm0.7'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 'auto'
        option mtu '1500'

config device 'wan_dev'
        option name 'ptm0'
        option mtu '1508'

config device 'ptm0_7'
        option name 'ptm0.7'
        option mtu '1508


results in:


ptm0      Link encap:Ethernet  HWaddr 11:22:33:44:55:67
          UP BROADCAST MULTICAST  MTU:1508  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

ptm0.7    Link encap:Ethernet  HWaddr 11:22:33:44:55:67
          UP BROADCAST MULTICAST  MTU:1508  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


I'm not sure if it's a bug or a feature we are seeing here.

Martin, you can workaround the issue my setting a mtu for the nas0 interface.
----------

More information can be found at the following URL:
https://bugs.lede-project.org/index.php?do=details&task_id=94#comment594



More information about the lede-bugs mailing list