[FS#360] Regression: no ipv6 with multiple interface

LEDE Bugs lede-bugs at lists.infradead.org
Wed Dec 28 06:10:04 PST 2016


A new Flyspray task has been opened.  Details are below. 

User who did this - bastien-roucaries (bastien-roucaries) 

Attached to Project - LEDE Project
Summary - Regression: no ipv6 with multiple interface
Task Type - Bug Report
Category - Packages
Status - Unconfirmed
Assigned To - 
Operating System - All
Severity - Medium
Priority - Very Low
Reported Version - Trunk
Due in Version - Undecided
Due Date - Undecided
Details - Hi,

I used something like this in order to have multiple ip adress:
/etc/config/network
config interface 'A_MAIN'
        option ifname 'br-BRIDGE_V20'
        option _orig_ifname 'br-BRIDGE_V20'
        option _orig_bridge 'false'
        option proto 'none'

config interface 'LAN_V20'
        option proto 'static'
        option ifname 'br-BRIDGE_V20'
        option netmask '255.255.255.0'
        option ipaddr '192.168.20.1'

config interface 'LAN_V20_6'
        option proto 'static'
        option ifname 'br-BRIDGE_V20'
        option ip6addr '2a01:e35:2f01:a61::1/64'

config interface 'LAN_V20_6L'
        option proto 'static'
        option ifname 'br-BRIDGE_V20'
        option ip6addr 'fd02:15b3:9237:20::1/64'

   
and /etc/config/dhcp something like:

config dhcp 'LAN_V20'
        option interface 'LAN_V20'
        option start '100'
        option limit '150'
        option leasetime '12h'

config dhcp 'LAN_V20_6'
        option interface 'LAN_V20_6'
        option ra 'server'
        option dhcpv6 'server'
        option ra_management '1'
        option ra_default '1'
        option master '1'
        option ignore '1'
config dhcp 'LAN_V20_6L'
        option interface 'LAN_V20_6L'
        option ra 'server'
        option dhcpv6 'server'
        option ra_management '1'
        option ra_default '1'
        option ignore '1'

Now it does not define ipv6 adress

More information can be found at the following URL:
https://bugs.lede-project.org/index.php?do=details&task_id=360



More information about the lede-bugs mailing list