[PATCH v6 02/39] mm/vma: introduce and use vma_[flags_]can_merge()
David Hildenbrand (Arm)
david at kernel.org
Tue Oct 13 08:19:53 PDT 2026
On 10/13/26 17:04, Lorenzo Stoakes (ARM) wrote:
> Replace the open-coded VMA_SPECIAL_FLAGS check in the VMA merge logic with
> two new functions vma_flags_can_merge() and vma_can_merge() and update the
> merge logic to use the former.
>
> This abstracts the check and expresses it in terms of the desired behaviour
> rather than an arbitrary and confusing VMA flag.
>
> This also lays the groundwork for making further improvements in VMA flag
> usage.
>
> Also update the userland VMA tests to reflect the change.
>
> No functional change intended.
>
> Reviewed-by: Gregory Price (Meta) <gourry at gourry.net>
> Reviewed-by: Zi Yan <ziy at nvidia.com>
> Reviewed-by: Suren Baghdasaryan <surenb at google.com>
> Acked-by: David Hildenbrand (Arm) <david at kernel.org>
> Signed-off-by: Lorenzo Stoakes (ARM) <ljs at kernel.org>
> ---
I'd have called it "vma_mergable" etc, because "can_merge" makes me imply a
"with what".
Acked-by: David Hildenbrand (Arm) <david at kernel.org>
--
Cheers,
David
More information about the kvm-riscv
mailing list