[RFC PATCH 02/34] ARM: mm: make 2-level pgd_t a scalar

David Laight david.laight.linux at gmail.com
Tue Jul 14 05:34:15 PDT 2026


On Mon, 13 Jul 2026 14:55:41 +0100
Yeoreum Yun <yeoreum.yun at arm.com> wrote:

> From: "David Hildenbrand (Arm)" <david at kernel.org>
> 
> We don't want pgd_t to be an array, as it prohibits returning it from a
> function, like pgdp_get().

If you use a two element structure the compiler/ABI might be able to
return that from a function in two registers.
That might make the entire mess more readable ...

	David



More information about the kvm-riscv mailing list