[kvm-unit-tests PATCH v2 05/18] scripts: Rename run_qemu_status -> run_test_status
Andrew Jones
andrew.jones at linux.dev
Tue Jan 21 07:55:48 PST 2025
On Mon, Jan 20, 2025 at 04:43:03PM +0000, Alexandru Elisei wrote:
> From: Alexandru Elisei <alexandru.elisei at gmail.com>
>
> For the arm/arm64 architectures, kvm-unit-tests can also be run using the
> kvmtool virtual machine manager. Rename run_qemu_status to run_test_status
> to make it more generic, in preparation to add support for kvmtool.
>
> Signed-off-by: Alexandru Elisei <alexandru.elisei at arm.com>
> ---
> arm/run | 4 ++--
> powerpc/run | 2 +-
> riscv/run | 4 ++--
> s390x/run | 2 +-
> scripts/arch-run.bash | 2 +-
> 5 files changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/arm/run b/arm/run
> index 6db32cf09c88..9b11feafffdd 100755
> --- a/arm/run
> +++ b/arm/run
> @@ -85,9 +85,9 @@ command+=" -display none -serial stdio"
> command="$(migration_cmd) $(timeout_cmd) $command"
>
> if [ "$UEFI_SHELL_RUN" = "y" ]; then
> - ENVIRON_DEFAULT=n run_qemu_status $command "$@"
> + ENVIRON_DEFAULT=n run_test_status $command "$@"
> elif [ "$EFI_USE_ACPI" = "y" ]; then
> - run_qemu_status $command -kernel "$@"
> + run_test_status $command -kernel "$@"
> else
> run_qemu $command -kernel "$@"
> fi
> diff --git a/powerpc/run b/powerpc/run
> index 27abf1ef6a4d..9b5fbc1197ed 100755
> --- a/powerpc/run
> +++ b/powerpc/run
> @@ -63,4 +63,4 @@ command="$(migration_cmd) $(timeout_cmd) $command"
> # to fixup the fixup below by parsing the true exit code from the output.
> # The second fixup is also a FIXME, because once we add chr-testdev
> # support for powerpc, we won't need the second fixup.
> -run_qemu_status $command "$@"
> +run_test_status $command "$@"
> diff --git a/riscv/run b/riscv/run
> index 73f2bf54dc32..2a846d361a4d 100755
> --- a/riscv/run
> +++ b/riscv/run
> @@ -34,8 +34,8 @@ command+=" $mach $acc $firmware -cpu $processor "
> command="$(migration_cmd) $(timeout_cmd) $command"
>
> if [ "$UEFI_SHELL_RUN" = "y" ]; then
> - ENVIRON_DEFAULT=n run_qemu_status $command "$@"
> + ENVIRON_DEFAULT=n run_test_status $command "$@"
> else
> # We return the exit code via stdout, not via the QEMU return code
> - run_qemu_status $command -kernel "$@"
> + run_test_status $command -kernel "$@"
> fi
> diff --git a/s390x/run b/s390x/run
> index 34552c2747d4..9ecfaf983a3d 100755
> --- a/s390x/run
> +++ b/s390x/run
> @@ -47,4 +47,4 @@ command+=" -kernel"
> command="$(panic_cmd) $(migration_cmd) $(timeout_cmd) $command"
>
> # We return the exit code via stdout, not via the QEMU return code
> -run_qemu_status $command "$@"
> +run_test_status $command "$@"
> diff --git a/scripts/arch-run.bash b/scripts/arch-run.bash
> index 8643bab3b252..d6eaf0ee5f09 100644
> --- a/scripts/arch-run.bash
> +++ b/scripts/arch-run.bash
> @@ -75,7 +75,7 @@ run_qemu ()
> return $ret
> }
>
> -run_qemu_status ()
> +run_test_status ()
> {
> local stdout ret
>
> --
> 2.47.1
Hmm, run_qemu_status() wraps run_qemu() so it seems appropriately named,
especially since the return value of run_qemu() has had QEMU-specific
return codes considered. It seems we should first decouple
run_qemu_status() from run_qemu() or to sanitize run_qemu() of anything
QEMU-specific and rename it to run_test() at the same time.
Thanks,
drew
More information about the kvm-riscv
mailing list