[PATCH v3 0/4] KVM: lockdep improvements

mlevitsk at redhat.com mlevitsk at redhat.com
Wed Apr 30 13:30:51 PDT 2025


On Wed, 2025-04-30 at 16:23 -0400, Maxim Levitsky wrote:
> This is	a continuation of my 'extract
> lock_all_vcpus/unlock_all_vcpus'
> patch series.
> 
> Implement the suggestion of using lockdep's "nest_lock" feature
> when locking all KVM vCPUs by adding mutex_trylock_nest_lock() and
> mutex_lock_killable_nest_lock() and use these functions	in the
> implementation of the
> kvm_trylock_all_vcpus()/kvm_lock_all_vcpus()/kvm_unlock_all_vcpus().
> 
> Those changes allow removal of a custom workaround that was needed to
> silence the lockdep warning in the SEV code and also stop lockdep
> from
> complaining in case of ARM and RISC-V code which doesn't include the
> above
> mentioned workaround.
> 
> Finally, it's worth noting that this patch series removes a fair
> amount of duplicate code by implementing the logic in one place.
> 
> Best regards,
> 	Maxim Levitsky
> 
> Maxim Levitsky (4):
>   arm64: KVM: use mutex_trylock_nest_lock when locking all vCPUs
>   RISC-V: KVM: switch to kvm_lock/unlock_all_vcpus
>   locking/mutex: implement mutex_lock_killable_nest_lock
>   x86: KVM: SEV: implement kvm_lock_all_vcpus and use it
> 
>  arch/arm64/include/asm/kvm_host.h     |  3 --
>  arch/arm64/kvm/arch_timer.c           |  4 +-
>  arch/arm64/kvm/arm.c                  | 43 ----------------
>  arch/arm64/kvm/vgic/vgic-init.c       |  4 +-
>  arch/arm64/kvm/vgic/vgic-its.c        |  8 +--
>  arch/arm64/kvm/vgic/vgic-kvm-device.c | 12 ++---
>  arch/riscv/kvm/aia_device.c           | 34 +------------
>  arch/x86/kvm/svm/sev.c                | 72 ++-----------------------
> --
>  include/linux/kvm_host.h              |  4 ++
>  include/linux/mutex.h                 | 17 +++++--
>  kernel/locking/mutex.c                |  7 +--
>  virt/kvm/kvm_main.c                   | 59 ++++++++++++++++++++++
>  12 files changed, 100 insertions(+), 167 deletions(-)
> 
> -- 
> 2.46.0
> 
> 


I forgot to send first patch in the series, resending.

Best regards,
	Maxim Levitsky




More information about the kvm-riscv mailing list