[PATCH v9 07/13] PCI: Refactor matching logic for pci_dev_acs_ops
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Fri Sep 18 13:13:30 PDT 2026
> Refactor the logic to match devices to pci_dev_acs_ops by factoring out
> the device matching loop into its own routine, pci_dev_acs_ops_get().
> This eliminates duplicate code between pci_dev_specific_enable_acs() and
> pci_dev_specific_disable_acs_redir(), and will also be used in a
> subsequent commit to check if a device requires device-specific
> enable_acs() during a Live Update.
>
> No functional change intended.
>
> Reviewed-by: Pranjal Shrivastava <praan at google.com>
> Reviewed-by: Pasha Tatashin <pasha.tatashin at soleen.com>
> Reviewed-by: Bjorn Helgaas <bhelgaas at google.com>
> Signed-off-by: David Matlack <dmatlack at google.com>
Sashiko has reviewed this patch and found no issues. It looks great!
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260918200640.887030-1-dmatlack@google.com?part=7
More information about the kexec
mailing list