[PATCH v7 12/15] kexec: Add kexec_load_other_segments() helper
sashiko-bot at kernel.org
sashiko-bot at kernel.org
Mon Oct 26 03:56:53 PDT 2026
> arm64, LoongArch and RISC-V duplicate the elf core header and initrd
> loading. Move it into a common helper with one arch hook for the boot
> parameters; a failure releases everything added for the attempt.
>
> Cc: Andrew Morton <akpm at linux-foundation.org>
> Cc: Baoquan He <baoquan.he at linux.dev>
> Cc: Mike Rapoport <rppt at kernel.org>
> Suggested-by: Mike Rapoport <rppt at kernel.org>
> Signed-off-by: Jinjie Ruan <ruanjinjie at huawei.com>
Sashiko has reviewed this patch and found no issues.
--
Sashiko AI review · https://sashiko.dev/#/patchset/20261026075201.699550-1-ruanjinjie@huawei.com?part=12
More information about the kexec
mailing list