[PATCH v3 07/10] crash_dump: Improve readability of config_keys_restore_store

Coiby Xu coiby.xu at gmail.com
Wed Aug 5 23:26:27 PDT 2026


On Wed, Aug 05, 2026 at 05:22:39PM +0530, Sourabh Jain wrote:
>
>
>On 29/07/26 09:06, Coiby Xu wrote:
>>config_keys_restore_store currently doesn't validate the user input
>>before restoring dm-crypt keys. Although it's not necessary for the case
>>of vmcore dumping, it's better to do it for the sake of consistency and
>>code readability. Also check the return code of
>>restore_dm_crypt_keys_to_thread_keyring.
>>
>>Fixes: 62f17d9df692 ("crash_dump: retrieve dm crypt keys in kdump kernel")
>>Signed-off-by: Coiby Xu <coiby.xu at gmail.com>
>>---
>>  kernel/crash_dump_dm_crypt.c | 13 ++++++++++---
>>  1 file changed, 10 insertions(+), 3 deletions(-)
>>
>>diff --git a/kernel/crash_dump_dm_crypt.c b/kernel/crash_dump_dm_crypt.c
>>index 3ee01996778f..1f4549956824 100644
>>--- a/kernel/crash_dump_dm_crypt.c
>>+++ b/kernel/crash_dump_dm_crypt.c
>>@@ -370,12 +370,19 @@ static ssize_t config_keys_restore_show(struct config_item *item, char *page)
>>  static ssize_t config_keys_restore_store(struct config_item *item,
>>  					  const char *page, size_t count)
>>  {
>>-	if (!restore)
>>-		restore_dm_crypt_keys_to_thread_keyring();
>>+	bool val;
>>-	if (kstrtobool(page, &restore))
>>+	if (kstrtobool(page, &val))
>>  		return -EINVAL;
>>+	if (val) {
>>+		if (restore) {
>>+			pr_warn("dm-crypt keys already restored!\n");
>>+			return count;
>>+		} else if (!restore_dm_crypt_keys_to_thread_keyring())
>>+			restore = true;
>>+	}
>>+
>>  	return count;
>
>Nit: returns count even when restore fails.

I'll change it in next version, thanks!

>
>Rest of changes looks good to me.
>Reviewed-by: Sourabh Jain <sourabhjain at linux.ibm.com>

And thanks for reviewing and ack'ing the patch!

>
>>  }
>

-- 
Best regards,
Coiby



More information about the kexec mailing list