[PATCH v6 0/2] arm64: kdump: simplify the reservation behaviour of crashkernel=,high

Baoquan He bhe at redhat.com
Sun May 14 23:02:57 PDT 2023


In v5 patch, Catalin helped review and acked the patch. However, an
uninitialized local varilable is warned out by static checker when Will
tried to merge the patch. And Will complained the code flow in
reserve_crashkernel() is hard to follow, required to refactor. While
when I tried to do the refactory, I feel it's not easy, the existing
several cases causes that.

To make the code easier understand, I try my best to compose a document
to introduce the background, concept and implementation strategies of 
crashkernel reservation. Hope it can help people to understand the code
flow a little more easily.

[PATCH v5] arm64: kdump: simplify the reservation behaviour of crashkernel=,high
https://lore.kernel.org/all/20230407022419.19412-1-bhe@redhat.com/T/#u

v5->v6:
- Fix the warning reported by static checker about "uninitialized symbol
'search_base'".
- Add a document Documentation/arm64/kdump.rst to explain how to reserve
  crashkernel.

Baoquan He (2):
  arm64: kdump: simplify the reservation behaviour of crashkernel=,high
  Documentation: add kdump.rst to present crashkernel reservation on
    arm64

 Documentation/arm64/kdump.rst | 103 ++++++++++++++++++++++++++++++++++
 arch/arm64/mm/init.c          |  44 +++++++++++----
 2 files changed, 137 insertions(+), 10 deletions(-)
 create mode 100644 Documentation/arm64/kdump.rst

-- 
2.34.1




More information about the kexec mailing list