[PATCH -next] fs/proc/vmcore: Fix 'sizez' kernel-doc warning in vmcore.c

Wang Hai wanghai38 at huawei.com
Fri Sep 18 08:51:48 EDT 2020


Fixes the following W=1 kernel build warning(s):

fs/proc/vmcore.c:458: warning: Excess function parameter 'sizez' description in 'vmcore_alloc_buf'

Rename sizez to size.

Signed-off-by: Wang Hai <wanghai38 at huawei.com>
---
 fs/proc/vmcore.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/proc/vmcore.c b/fs/proc/vmcore.c
index c3a345c28a93..bfb0aa4d63e4 100644
--- a/fs/proc/vmcore.c
+++ b/fs/proc/vmcore.c
@@ -446,7 +446,7 @@ static const struct vm_operations_struct vmcore_mmap_ops = {
 
 /**
  * vmcore_alloc_buf - allocate buffer in vmalloc memory
- * @sizez: size of buffer
+ * @size: size of buffer
  *
  * If CONFIG_MMU is defined, use vmalloc_user() to allow users to mmap
  * the buffer to user-space by means of remap_vmalloc_range().
-- 
2.17.1




More information about the kexec mailing list