Guest shutdown problem with kexec --load ... ; kexec --exec running under Xen on CentOS 7 (x86_64)

Corey Ashford cjashfor at
Fri Jul 21 13:27:22 PDT 2017

The platform is a PVHVM guest of CentOS 7 (x86_64) running on a 
XenServer (version 6.5 and 7.2 both have the same behavior).

This is the kexec-tools rpm build we are using:


If we run these two commands:

kexec --load /boot/vmlinux-<current kernel> --initrd=/boot/initramfs 
<corresponding initramfs for current kernel> --reuse-cmdline

kexec --exec

The first line succeeds without errors, but the second one causes the VM 
to immediately shutdown, and there's no further output on the console. 
We've tried adding a number of different kernel command line options, 
such as: debug=1 early_printk=xen loglevel=9

We've also tried blacklisting the PV drivers.

This sequence works fine on KVM, VMware, and also on bare-metal machines.

Is this expected behavior on Xen with CentOS 7.x?  We have scoured the 
kexec-tools mailing list, googled extensively, and haven't come up with 
much help.  We've also tried changing various kernel config parameters 
related to Xen, but the behavior doesn't change.

Any info, debugging advice, suggestions would be appreciated.

Thanks for your consideration,

- Corey

Corey Ashford
IBM Embedded Linux, software engineer
cjashfor at

More information about the kexec mailing list