[RFC PATCH 00/13][V3] kexec: A new system call to allow in kernel loading

Vivek Goyal vgoyal at redhat.com
Thu Jun 5 08:01:59 PDT 2014

On Thu, Jun 05, 2014 at 04:31:34PM +0800, Dave Young wrote:

> > +	ret = kexec_file_load(kernel_fd, info.initrd_fd, info.command_line,
> > +			info.command_line_len, info.kexec_flags);
> Vivek,
> I tried your patch on my uefi test machine, but kexec load fails like below:
> [root at localhost ~]# kexec -l /boot/vmlinuz-3.15.0-rc8+ --use-kexec2-syscall
> Could not find a free area of memory of 0xa000 bytes ...

Hi Dave,

I think this message is coming from kexec-tools from old loading path. I
think somehow new path did not even kick in. I tried above and I got
-EBADF as I did not pass initrd. Can you run gdb on kexec and see if
you are getting to syscall or run strace.

> Another issue is that the syscall should allow load kernel only without initrd

Agreed. Currently my code is not handling it. I am thinking of ways how to
make passing initrd fd optional.

> and
> cmdline since kernel can mount root and embed cmdline in itself.

Passing command line is already optional. I tried it and kexec loaded


More information about the kexec mailing list