[PATCH v4 07/12] efi: passing kexec necessary efi data via setup_data
Dave Young
dyoung at redhat.com
Fri Nov 29 04:46:52 EST 2013
On 11/27/13 at 10:17am, Matt Fleming wrote:
> On Wed, 27 Nov, at 12:52:37PM, Dave Young wrote:
> > To make it more readable, I will change them like below:
> >
> > p = efi_runtime_map;
> > md = efi_setup->map;
> > for (i = 0; i < nr_efi_runtime_map; i++) {
> > [...]
> > md += 1;
> > }
>
> Actually, md++ is the canonical way to write this.
Ok.
>
> > >
> > > > + efi_map_region_fixed(md);
> > > > + size = md->num_pages << PAGE_SHIFT;
> > > > + end = md->phys_addr + size;
> > > > +
> > > > + systab = (u64) (unsigned long) efi_phys.systab;
> > > > + if (md->phys_addr <= systab && systab < end) {
> > > > + systab += md->virt_addr - md->phys_addr;
> > > > + efi.systab =
> > > > + (efi_system_table_t *) (unsigned long) systab;
> > > > + }
> > > > + if (efi_runtime_map) {
> > > > + memcpy(p, md, memmap.desc_size);
> > > > + p += memmap.desc_size;
> > > > + }
> > >
> > > Is this if () needed? Is it possible to enter the loop and have
> > > 'efi_runtime_map' be NULL?
> >
> > Yes, it is needed. if efi_runtime_map kmalloc fails I only print error, do not
> > return so kernel can still boot, just kexec on efi will not work that has been
> > put in the error message.
>
> OK. On second thought, is there any way to turn the above code into a
> call to efi_save_runtime_map()? Because you've basically duplicated that
> code and I can definitely envisage the two code paths fragmenting over
> time, e.g. when someone makes changes to one but not the other.
OK, will consider to reuse the function.
Thanks
Dave
More information about the kexec
mailing list