[PATCH v2 4/7] xen: Enforce page size only when xen-syms file is used

Daniel Kiper daniel.kiper at oracle.com
Fri Jul 19 09:44:51 EDT 2013


On Fri, Jul 19, 2013 at 06:20:24PM +0900, Atsushi Kumagai wrote:
> On Tue, 16 Jul 2013 14:32:06 +0200
> Daniel Kiper <daniel.kiper at oracle.com> wrote:
>
> > Enforce page size only when xen-syms file is used.
> > Otherwise its size could be read from VMCOREINFO
> > file or /proc/vmcore file.
> >
> > Signed-off-by: Daniel Kiper <daniel.kiper at oracle.com>
> > ---
> >  makedumpfile.c |    4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/makedumpfile.c b/makedumpfile.c
> > index b42565c..b4abbe5 100644
> > --- a/makedumpfile.c
> > +++ b/makedumpfile.c
> > @@ -7324,8 +7324,6 @@ initial_xen(void)
> >  #endif
> >  	if (!init_xen_crash_info())
> >  		return FALSE;
> > -	if (!fallback_to_current_page_size())
> > -		return FALSE;
> >  	/*
> >  	 * Get the debug information for analysis from the vmcoreinfo file
> >  	 */
> > @@ -7340,6 +7338,8 @@ initial_xen(void)
> >  		set_dwarf_debuginfo("xen-syms", NULL,
> >  				    info->name_xen_syms, info->fd_xen_syms);
> >
> > +		if (!fallback_to_current_page_size())
> > +			return FALSE;
> >  		if (!get_symbol_info_xen())
> >  			return FALSE;
> >  		if (!get_structure_info_xen())
>
> This patch has no problem, but I would like to fix a bit for readability.
> So could you move the position of fallback_to_current_page_size() to after
> this block like initial() ?
>
> makedumpfile.c::initial()
>
>    2972         if (!info->page_size) {
>    2973                 /*
>    2974                  * If we cannot get page_size from a vmcoreinfo file,
>    2975                  * fall back to the current kernel page size.
>    2976                  */
>    2977                 if (!fallback_to_current_page_size())
>    2978                         return FALSE;
>    2979         }

Sure. Should I repost whole series or just only this patch?

Daniel



More information about the kexec mailing list