Kexec on Macbook Pro 8,1

Jan Frederick Eick j.f.eick at
Tue Nov 20 13:19:41 EST 2012

Hi there,

I'm not sure if this is the right place to ask my questions, but I found 
very sparse documentation when it comes to solve problems with kexec.

I'm running an arch linux setup on my Macbook Pro 8,1 (Kernel 
3.6.7-1-ck) with an i915 vga adapter (Intel HD Graphics 3000) and I try 
to use kexec with systemd.

Systemd uses a service file to load the new Kernel image before 
executing kexec:
ExecStart=/sbin/kexec -l /boot/vmlinuz-linux-ck \

I use a system with an encrypted root partition, but I ran into the 
exact same issue with my old setup (without encrypted root).

But when I issue the kexec call I can read the line
"Starting new kernel" and then my screen is garbled. I read a lot about 
issues with the vga console, so I tried to reach my system by ssh, but 
it didn't work.

I uploaded a "screenshot" here:

Some more info:
[kernel commandline]
BOOT_IMAGE=/vmlinuz-linux-ck root=/dev/mapper/main-root ro 
cryptdevice=/dev/sda6:main pcie_aspm=force i915.i915_enable_rc6=1 
i915.lvds_downclock=1 i915.i915_enable_fbc=1 elevator=bfq verbose

MODULES="ahci libahci ehci-hcd uhci-hcd ext3 ext4 vfat"
HOOKS="base udev keymap fsck autodetect pata scsi sata usbinput encrypt 
lvm2 uresume filesystems"

Does anyone have a hint how I could "debug" this issue or get kexec to 
work on my system?

Kind regards


More information about the kexec mailing list