[PATCH] Correct magic varible of function name in debug code
Dave Young
dyoung at redhat.com
Mon Jan 9 05:13:06 EST 2012
On 01/09/2012 06:02 PM, Han Pingtian wrote:
> The magic varible of function name should be uppercase.
>
> Signed-off-by: Han Pingtian <hanpt at linux.vnet.ibm.com>
> ---
> kexec/crashdump.c | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/kexec/crashdump.c b/kexec/crashdump.c
> index e7ac42c..847d080 100644
> --- a/kexec/crashdump.c
> +++ b/kexec/crashdump.c
> @@ -103,7 +103,7 @@ int get_crash_notes_per_cpu(int cpu, uint64_t *addr, uint64_t *len)
> *addr = (uint64_t) temp;
> *len = MAX_NOTE_BYTES; /* we should get this from the kernel instead */
> #ifdef DEBUG
> - printf("%s: crash_notes addr = %Lx\n", __function__, *addr);
> + printf("%s: crash_notes addr = %Lx\n", __FUNCTION__, *addr);
> #endif
>
> fclose(fp);
Hi, Han
Glad to see you here.
I post a similar fix for this issue, please see:
http://lists.infradead.org/pipermail/kexec/2011-December/005889.html
--
Thanks
Dave
More information about the kexec
mailing list