FW: kexec to launch second kernel

Kagathara, Satish satish.kagathara at diebold.com
Tue Jun 22 14:32:36 EDT 2010



From: Kagathara, Satish 
Sent: Tuesday, June 22, 2010 9:22 AM
To: 'Simon Horman'
Subject: kexec to launch second kernel




I found your email id from kexec site. I am using kexec to start a second kernel (grub4dos and then windows). I have installed Fedora Core 13 first and Windows XP later on disk. I am using kexec-tools-2.0.1.tar.bz2 and I just extracted it and ran ./configure and make commands.


I am using following commands to launch a second kernel -


Kexec -l /sbin/grub.exe

Kexec -e


First I tried grub4dos 0.4.4 but did not work then tried grub4dos 0.4.2 but that too isn't working. I have copied grub.exe to /sbin. Also, copied menu.lst on windows partition. I am facing following problems with them -


Stuck at Launching GRUB when I use grub4dos 0.4.4 - It just stuck at Launching GRUB screen. 


Keyboard not working when I use grub4dos 0.4.2 - With 0.4.2 version, grub4dos starts, shows some entries on screen then says failure. Then it tries to find /menu.lst but it doesn't (I don't know why as I have copied menu.lst in Windows partition (hd0,1). Then it neither finds menu.lst at /boot/grub/ or /grub. So it gives grub4dos command prompt but I can't enter any thing as keyboard is not at all responding. Even Caps Lock, Num Lock LED not blinking.


In both cases, I also tried using -command-line option in kexec -l /sbin/grub.exe and given -config-file but did not work.


Menu.lst -

Color black/cyan yellow/cyan




Title Start Windows

                Rootnoverify (hd0,1)

                Chainloader +1



Sequence is - Fron GNU GRUB start FC13 à Run kexec commands from terminal à Should start grub.exe (grub4dos) à grub4dos should find menu.lst and launch Windows XP. 


Please note that I can boot Windows XP from GNU GRUB with same menu.lst as above and also when I launch grub4dos as kernel from GNU GRUB and then grub4dos finds menu.lst and start Windows XP. I can't launch Windows XP using kexec.


Please let me know whether I am following correct steps and using right versions or not and a possible solution for this problem. 





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/kexec/attachments/20100622/9b105c23/attachment.html>

More information about the kexec mailing list