No subject

Fri Nov 6 13:01:15 EST 2009

address. 0x7EC44A14

The kdump kernel boot param
root=/dev/ram0 nmi_watchdog=0 irqpoll maxcpus=1 reset_devices
 memmap=exactmap memmap=640K at 0K memmap=130412K at 16384K elfcorehdr=146796K

With the information  that cp fails at file offset 1989877760 bytes
which maps to physical address  0x7EC44A14 how do I further analyze
the issue.?

Any pointers ?

---------------------- snippet of readelf -l /proc/vmcore output
Enter shell command >/sbin/readelf -l /proc/vmcore

Elf file type is CORE (Core file)
Entry point 0x0
There are 23 program headers, starting at offset 64

Program Headers:
  Type           Offset                              PhysAddr
               FileSiz                        MemSiz
   Flags      Align
 LOAD           0x000000007699f5ec       0x000000007ec32000
0x0000000000013000     0x0000000000013000      RWE    0
 LOAD           0x00000000769b25ec      0x000000007ec46000

On Wed, Feb 10, 2010 at 11:53 PM, Bernhard Walle <bernhard at> wrote:
> Am 10.02.2010 um 19:46 schrieb Sujit V:
>> Tried readelf on the /proc/vmcore but gave the below error. The
>> readelf worked correctly on another binary.
>> kdump shell>/sbin/readelf -l /proc/vmcore
>> readelf: Error: Cannot stat input file /proc/vmcore.
> My only guess is that readelf has no large file support (see Could you please execute "strace readelf -l /proc/vmcore"?
> Regards,
> Bernhard

More information about the kexec mailing list