kexec with vmware esx 3.0.2

Zachary Amsden zach at
Sat Oct 4 01:41:25 EDT 2008

On Fri, 2008-10-03 at 16:45 -0700, Yinghai Lu wrote:
> On Fri, Oct 3, 2008 at 3:58 PM, Zachary Amsden <zach at> wrote:
> > On Fri, 2008-10-03 at 15:51 -0700, Yinghai Lu wrote:
> >
> >> ok, my question is: anyone tried to use kexec with vmware?
> >
> > Do you mean has anyone tried to use kexec in Linux running under VMware,
> that should work

It does.

> > or do you mean has anyone tried to use kexec to start ESX?
> yeah, that is strange request. hope it work..

Well you're a braver soul than me.  If your hardware is really so horked
you can't boot Linux without noacpi, I seriously doubt the vmkernel will
run properly.  You might be able to kexec the Linux pre-bootstrapping
bit, the the vmkernel is not even close to the same code lineage and has
a limited and very fixed set of hardware requirements.  And you are
talking about fixing up the MP table and interfering with the custom
boot process?  I would not for any amount of money want to find out what
kind of squirrels are hiding in that nest.

I mean can you run Oracle on an overclocked budget brand laptop?  Well,

But you're talking about running an enterprise class application on
dodgy hardware, and that is seriously stretching the realms of sanity.

I kinda don't think this is really interesting to the folks on LKML, you
could try asking over on the VMware forums.

Good luck,


More information about the kexec mailing list