kexec/kdump of a kvm guest?

Alexander Graf agraf at
Thu Jul 24 04:39:31 EDT 2008

On Jul 24, 2008, at 2:13 AM, Mike Snitzer wrote:

> On Sat, Jul 5, 2008 at 7:20 AM, Avi Kivity <avi at> wrote:
>> Mike Snitzer wrote:
>>> My host is x86_64 RHEL5U1 running with kvm-70 (kvm-intel).
>>> When I configure kdump in the guest (running and force a
>>> crash (with 'echo c > /proc/sysrq-trigger) kexec boots the kdump
>>> kernel but then the kernel hangs (before it gets to /sbin/init et  
>>> al).
>>> On the host, the associated qemu is consuming 100% cpu.
>>> I really need to be able to collect vmcores from my kvm guests.  So
>>> far I can't (on raw hardware all works fine).
>> I've tested this a while ago and it worked (though I tested regular  
>> kexecs,
>> not crashes); this may be a regression.
>> Please run kvm_stat to see what's happening at the time of the crash.
> OK, I can look into kvm_stat but I just discovered that just having
> kvm-intel and kvm loaded into my kernel actually prevents

Is your host or your guest kernel? It's very unlikely that  
you loaded kvm modules in the guest.

> the host from being able to kexec/kdump too!?  I didn't have any
> guests running (only the kvm modules were loaded).  As soon as I
> unloaded the kvm modules kdump worked as expected.
> Something about kvm is completely breaking kexec/kdump on both the
> host and guest kernels.

I guess the kexec people would be pretty interested in this as well,  
so I'll just CC them for now.
As you're stating that the host kernel breaks with kvm modules loaded,  
maybe someone there could give a hint.


More information about the kexec mailing list