[PATCH 1/5] Rename vmcoreinfo's macros returning the size
horms at verge.net.au
Fri Nov 16 13:26:51 EST 2007
On Fri, Nov 16, 2007 at 11:33:02AM +0900, Ken'ichi Ohmichi wrote:
> VMCOREINFO_SIZE() should be renamed VMCOREINFO_STRUCT_SIZE() since it's always
> returning the size of the struct with a given name. This change would allow
> VMCOREINFO_TYPEDEF_SIZE() to simply become VMCOREINFO_SIZE() since it need not
> be used exclusively for typedefs.
> This discussion is the following:
> Signed-off-by: Ken'ichi Ohmichi <oomichi at mxs.nes.nec.co.jp>
> Acked-by: David Rientjes <rientjes at google.com>
As far as name changes go, this one looks good to me.
Acked-by: Simon Horman <horms at verge.net.au>
More information about the kexec