PATCH/RFC: [kdump] fix APIC shutdown sequence

Martin Wilck martin.wilck at
Wed Aug 8 08:04:38 EDT 2007

Hi Vivek,

>>> How bad is it if you just run with irqpoll in the kdump kernel?
>>> If running with irqpoll is usable that is probably preferable
>>> to putting in a hardware work around we can survive without.
>> Yes, I tried that. No effect.
> Martin, at least irpoll should have worked. I am assuming your timer
> interrupts are coming in second kernel. In that case we are not
> dependent at all on actually receiving device interrupt. Polling should
> take care of it.

You are right. I just tested irqpoll again , and it does works even if the error
(detected by the IRR bit set in the IO-APIC) occurs.

I have no idea what went wrong when I tried "irqpoll" last time. But I was
using a different kernel, controller firmware, driver, and HW configuration,
so it can probably be explained somehow. Unfortunately, the unsuccessful early
attempts caused me to conclude prematurely that "irqpoll" didn't help. I admit
I didn't understand "irqpoll" fully until just now.

> What is that device which is not working? What is the success criterion?

It's a LSI megaraid_sas "zero channel RAID" (ZCR) controller. The system has an
on-board LSI 1068 (mptsas). If you put the ZCR in a certain PCI slot, the
1068 is hidden from the system, which sees the megaraid_sas controller
(1000:0413) instead of the 1068. The ZCR internally uses the 1068 as low-level

The success criterion was that the disks on the ZCR were successfully detected
and the dump was written.


Martin Wilck
PRIMERGY System Software Engineer

Fujitsu Siemens Computers GmbH
Heinz-Nixdorf-Ring 1
33106 Paderborn

Tel:			++49 5251 8 15113
Fax:			++49 5251 8 20409
Email:			mailto:martin.wilck at
Company Details:

More information about the kexec mailing list