[PATH 0/1] Kexec jump - v2 - the first step to kexec based hibernation

Pavel Machek pavel at ucw.cz
Sun Aug 5 14:55:58 EDT 2007


> > root at amd:~# kexec -p /data/l/linux/arch/i386/boot/bzImage --append="init=/bin/bash kexec_jump_buf_pfn=`cat /sys/kernel/kexec_jump_buf_pfn`"
> > Could not find a free area of memory of 9000 bytes...
> > locate_hole failed
> > root at amd:~#
> > 
> > What am I doing wrong?
> The kexec-tools version 1.101 does not work perfectly with relocatable
> kernel. This would have been solved if I worked against kexec-tools
> testing tree. I will work against testing tree in the next version.
> But, with some trick, it can work. When configure kernel, make sure the
> following option is set:
> CONFIG_PHYSICAL_START=0x4000000 # if crashkernel=<XX>M at 64M

Did the trick, I got the kernel to load, and it even attempted
exec... but I got doublefault (or what is it?)

Int 6: ... EIP: c4739906. Address is in reserve_bootmem_core.

Do I have to disable ACPI completely? I tried with acpi=off,
nosmp... but problem does not seem device related.
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

More information about the kexec mailing list