Unable to build wpa_supplicant: undefined reference to `mka_sci_u64'

Jouni Malinen j at w1.fi
Sun Jun 2 03:31:31 PDT 2019


On Fri, May 31, 2019 at 01:41:18PM +0000, Conrad Kostecki wrote:
> I am hitting here a problem, with compilation.
> 
> When I do enable CONFIG_PRIVSEP together with MACSEC, I am not able to
> compile wpa_supplicant.
> My config can be found here: http://dpaste.com/13JG46V
> Buildlog here: http://dpaste.com/0FAQ2XX
> 
> Any ideas?

CONFIG_PRIVSEP=y does not have sufficient support for the new driver
interface functions used for MACsec, so this combination cannot be used
at least for now. The particular build issue is actually somewhat
independent of that since the driver wrapper code (which would be in
privileged part) seems to be using functions that are defined in the
unprivileged component. That itself might be easy to work around, but
that won't help much due to that main issue of the driver interface
functions not being supported in the privilege separate path.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the Hostap mailing list