PEAP, MSCHAPV2 and Raspberry Pi 3

Jordan J jordandev678 at gmail.com
Tue Jun 26 09:21:04 PDT 2018


Hey everyone,

I'm having an issue with WPA-EAP that I've so far been unable to debug.

I've tried all the usual things that looking back through Google and
the mail archives suggest (disable tls versions, peaplabel, specify
explicit protocols, etc.) but with no luck.

What I have stumbled upon is that noobs (raspberry pi installer) is
able to connect successfully with the most basic of config files, yet
when I boot into Raspbian it fails both with the same config file and
the more complex ones with the various potential fixes. That lead me
to compare wpa_supplicant versions - working version is 2.5, Raspbian
is 2.4, ah-ha!

However, after manually building both 2.5 and 2.6 in Raspbian they
still don't connect either. So at this point I'm a bit lost. I'd take
that to mean wpa_supplicant probably isn't the core issue but I don't
have enough exposure to wpa_supplicant logs to be able to parse out
where the problem likely is (driver, OpenSSL, etc.). So I'm hoping
someone can spare some time to have a look and point me in the right
direction.

The debug logs (-dd) can be found here:
        Working log - https://pastebin.com/MeqpF8tm
        Failing log - https://pastebin.com/F8sqXxB1

The wpa_supplicant.conf that worked in noobs:
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=GB
    network={
        ssid="eduroam"
        key_mgmt=WPA-EAP
        identity="[Removed]"
        password="[Removed]"
    }

Let me know if there is any other information that would be useful.

Thanks for any help that can be provided!



More information about the Hostap mailing list