Hostapd won't start, need help debugging please.

Darren Share darren at
Sun Jun 5 23:27:19 PDT 2016

Hi there. I have a mini server running Debian and acting as an AP. It 
used to run Squeeze and I have recently updated to Jessie with systemd. 
I have a cron job that restarts hostapd every morning because my TV set 
top box stops talking to the network if it stays connected too long. 
Since upgrading to Jessie the cron job fails to restart hostapd some 
mornings - maybe once per week. The cron job literally runs 
"/etc/init.d/hostapd restart", nothing fancy. When this happens, I also 
can't start it manually with /etc/init.d/hostapd start. I get the 
systemctl message that looks like it's worked, but hostapd doesn't run. 
I can't see anything in the syslog as to why this is. If I run hostapd 
from the command line - "hostapd -B /etc/hostapd.conf" - it starts fine. 
So the problem seems to be with systemctl starting it, but it's not 
reliably reproducible. I think the other morning I ran 
"/etc/init.d/hostapd stop", and then "/etc/init.d/hostapd start" and it 
did work OK but I'm still not sure why. Note: the same is true if I run 
"service start hostapd" and "systemctl start hostapd". Can anyone 
suggest how I can debug what's going on?


More information about the Hostap mailing list