HostAPd WPA Enterprise fails on Windows 10

Thomas d'Otreppe tdotreppe at
Mon Dec 12 14:23:50 PST 2016


I have been playing with Hostapd patched for WPE on Kali. It is a
patch to make HostAPd (2.6) an Enterprise AP and accept and log all
credentials entered.

With a stock configuration, it works just fine on most OSes (tested:
Ubuntu 16.04, 16.10, iOS 10.1 and 10.2) but Windows 10 (14393) fails
without much explanation. However, in a set-up where HostAPd forwards
the request to Freeradius 3.0.12, it works just fine with Windows 10.

There is a ticket about the issue:

To summarize the ticket, by enabling debug (-d) when running hostapd,
it seems like it is failing right before switching to Phase 2. It
doesn't seem to get the data for phase 2 correctly as you can see in
the log excerpt in the ticket.

According to some forums, Windows might have had some issue with TLS
v1.2 so I tried to recompile with TLS v1.2 disabled but it still
failed (and also tried disabling also v1.1, no success). I also tried
latest hostapd git from a day or 2 ago and the problem still persists.

Can anybody shed some light on what/where the problem is or if there
is something wrong with the set-up?
If needed, I kept the success and failure logs and I can send them for analysis.


More information about the Hostap mailing list