wpa_supplicant with netlink on Android

Utku Günay Acer utkuacer at gmail.com
Tue Aug 23 04:39:01 PDT 2016

Hi all,

I am trying to add a number of public action frame definitions to
wpa_supplicant/hostapd (running version 2.5-devel). I run the
wpa_supplicant side on both Raspberry Pi and an android phone through
aosp. The hostapd runs in an OpenWRT router. In the system, one probe
from the STA is replied by the action frame just before the probe

Now I am having no problem with the OpenWRT or RPi. Even though RPi
runs the same code, it does not have this problem. However, on
Android, I can not receive any of these action frames even though a
near-by sniffer captures these frames that are sent by the router. The
phone does receive probe responses but not these action frames. So,
channel hopping shouldn't be the reason.

By the way, I use the nl80211_register_action_frame(bss, (u8 *)
"\x04\x80", 2) command in the beginning of the execution to register
the public action frames with subtype 0x80 and I get no error. I tried
receiving public action frames with other action types such as
WLAN_PA_20_40_BSS_COEX that is defined in ieee802_11_defs.h. However,
I am only able receive action frames associated with GAS, i.e.

Does anyone have any similar experience? Is there any chance that
driver or firmware filters these frames out? I would appreciate any

Thank a lot

More information about the Hostap mailing list