hostapd Won't Launch

Ayron Jungren ajungren
Fri Jan 25 09:22:40 PST 2013

On Thu, Jan 24, 2013 at 8:17 PM, Mihai Moldovan <ionic at> wrote:
> Just tested it. Doesn't happen here... then again, what are your USE flags?
> If you can, please post your config file.

USE="crda ipv6 ssl wps -debug -logwatch -madwifi"

I've tried tons of config files, including `/dev/null' (thinking it
would at least produce an error). Right now I'm using a config based
on changed to
have my SSID and PSK. That being said, after I sent the email to the
mailing list, I tried the binary from Ubuntu's hostapd package and it
works just fine so it's not a configuration issue; there's a problem
with Gentoo's ebuild somewhere, so I'll probably be filing a bug on
Gentoo's Bugzilla.

> That's normal. It won't background itself, unless you start it with -B. Could
> you please be more clear, indicating what does happen and what not?

I'm aware of that, I was merely pointing out that there wasn't a bug
that set the flag telling hostapd go into the background without -B.
What happens is absolutely nothing. As I mentioned, `strace' shows it
exiting immediately after it reads the configuration file, without
touching the Wi-Fi card. I don't even get the `Configuration file:
/etc/hostapd/hostapd.conf' message.

Thanks for your time,
Ayron Jungren

More information about the Hostap mailing list