Need desperate help - wireless 802.1X problem

Dan Williams dcbw
Thu Sep 27 07:52:11 PDT 2012

On Thu, 2012-09-27 at 17:09 +0300, Jouni Malinen wrote:
> On Thu, Sep 27, 2012 at 12:55:41PM +0000, Alper Yilmaz wrote:
> > I copy pasted the question from forum post below,. he forum post
> > contains all necessary information (system info, logs, etc.)
> > (
> It looks like everything went fine as far as wpa_supplicant is
> concerned.
> > I need desperate help regarding my wireless connection problem. I
> > cannot connect to my university's wireless network which uses
> > WEP802.1X security.
> I've never tested dynamic WEP keys with iwlwifi and 5100, so I'm not
> sure what to expect from the combination. Anyway, the next step in
> debugging this would be to collect some driver logs.. Sorry to bounce
> you back, but linux-wireless would really be the correct list for this
> ;-).

It worked for me a month ago with iwlwifi, Intel 5100, and 3Com access
points (AP2750), 3Com controller (WXR100) backed by freeradius.  OS was
Fedora 17 using a 3.5 kernel, wpa_supplicant 1.0.  I would expect it to


> > One of HostAP members suggested using different dhclients, and I tried
> > udhcpc and dhcpcd with wicd. I didn't observe any changes and I'm not
> > sure if dhcp clients weren't run properly or they ran but failed to
> > obtain ip address.
> I would assume something goes wrong with key configuration and either
> unicast or broadcast packets (or both) don't get through.

More information about the Hostap mailing list