Station sent an invalid association request?

Otto Kekäläinen otto
Fri Jan 13 12:25:40 PST 2012


2012/1/13 Jouni Malinen <j at>:
>> I don't think that Asus cares much about how a "bug" in an old EeePC
>> 1000HE, so if you want to punish misbehaving stations in hostapd, I
>> guess I must go back to my old setup? Are you sure the error is not in
>> my conf, or could there be some setting in the conf to allow the EeePC
>> to work?
> That station is seriously broken as far as WPA2 is concerned. You cannot
> cause something like this with configuration. You may be able to trigger
> that bug with some configurations, but it is just not possible to use
> that station with WPA2 if it sends association request frames like shown
> in the sniffer trace.
>> I would much rather use this new atheros card and hostapd on my home
>> server than go back to using my old external Buffalo Airstation G54 as
>> the WLAN AP...
> Have you tried using that station with that other AP using the same WPA2
> configuration?

With hostpad I use the same SSID and passphrase as I used in the old
Buffalo box, and they both use WPA, but I don't I can't see the
internals of the Buffalo to say what kind of WPA it is and how it
differs from my hostapd.conf.

Thanks for the pointer tough that the error could be in the WPA config.
In hostapd.conf I tried changing wpa=3 to wpa=1 which didn't work, but
then I tried wpa=2 that enables radius. Even though I don't use any
radius, just simple passphrase, it started to work!

Thanks for your help!

PS. For the future, the debug output of hostapd -dd could be a little
bit more verbose with "human readable" strings. I had one laptop that
tried to connect with the wrong passphrase. Instead of outputting
"Passphrase did not match" hostapd -dd gave some (to me) cryptic
messages. Only when I ran it with --show-keys I realized that the
passphrase didn't match and after that everything worked. Now with the
second laptop I got the "Station sent an invalid association request"
which wasn't terribly helpful. It would have been easier if hostapd
-dd would have said "Station sent an invalid association request for
this WPA mode. Try different WPA mode" etc.

Luckily you are very kind at this list and I got this solved using wpa=2 :)

More information about the Hostap mailing list