Station sent an invalid association request?

Jouni Malinen j
Wed Jan 11 21:21:32 PST 2012

On Wed, Jan 11, 2012 at 11:29:16PM +0200, Otto Kek?l?inen wrote:
> However I tried to connet to the WLAN with an Asus EeePC 1000HE laptop
> with a rt2860 WLAN card and running Ubuntu 10.04, it's network manager
> just keeps loading forever after asking for the password.
> When I ran hostapd -bb it shows as the error "Station sent an invalid
> association request". What does that mean? What is the error exactly?

It indicates that the Association Request frame sent by the station
could not be parsed successfully, i.e., most likely, there was an
invalid information element in it.

> I tried all kinds of configurations changing hostapd.conf, but nothing
> seems to fix this. The same laptop connected just fine to my old WLAN,
> so the error is not in the EeePC.

Well, I would disagree with that conclusion. Anyway, AP configuration
changes won't help with this - you would need to modify the source code
to allow invalid frames..

Would it be possible for you to capture that Association Request frame
with a sniffer (say, tcpdump or wireshark)? It would be interesting to
see what exactly was wrong with it.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list