rtl8191se and EAPOL key time-outs

Paul Flinders paul
Sat Dec 15 08:58:15 PST 2012

I'm scratching my head a bit trying to configure an access point with 

I have a Foxconn "nettop" box, its main role in life is going to be as 
an Asterisk PBX but as it will be powered up 24/7 and has a wifi card 
I'd also like to configure it as an AP to fill in some areas of poor 
signal around the house.

It has Scientific Linux 6.3 installed (a RHEL 6.3 spin) with kernel 
version 2.6.32-279.14.1.el6.i686, the wifi card is based on an 
RTL8191SEvA 802.11b/g/n chip.

This chip isn't supported in the stock SL kernel - Realtek provide two 
sets of driver source code, an "older" version for up to 2.6.23 kernels 
and a newer version for 2.6.24 and up. The older version compiles 
cleanly but doesn't offer any interface that hostapd understands. The 
newer version offers a nl80211 compatible interface but did need a 
little help to compile because it looks like RedHat have back ported 
some changes from later kernels into the 2.6.32 kernel that RHEL/SL 6.3 

I configured hostapd with:
wpa_key_mgmt=WPA-PSK WPA-EAP
wpa_pairwise=TKIP CCMP

However when any client tries to associate it immediately de-associates 
again having failed the EAPOL key handshake.

If I run with debug enabled I see a lot of

WPA: 98:4b:4a:04:45:dc WPA_PTK entering state PTKSTART
wlan0: STA 98:4b:4a:04:45:dc WPA: sending 1/4 msg of 4-Way Handshake
WPA: Send EAPOL(version=2 secure=0 mic=0 ack=1 install=0 pairwise=8 
kde_len=0 keyidx=0 encr=0)
WPA: Use EAPOL-Key timeout of 1000 ms (retry counter 2)
wlan0: STA 98:4b:4a:04:45:dc WPA: EAPOL-Key timeout

in the output.

I have tried this with various clients including Windows 7, two Android 
phones, Windows XP and Fedora 14 - all behave in the same manner.

When hostapd starts it creates the mon.wlan0 interface and places it in 
monitor mode. If I sniff that interface I can see the probe requests and 
association requests from the client. I can also see the EAPOL key 
packets on their way out (for some reason two packets per hostapd retry 
- not sure if that is significant). I do _not_ see any responses to the 
EAPOL packets.

I have tried to sniff the wlan to see what is present on the air but 
Wireshark doesn't want to do that on any of the platforms I have it 
installed. Using Wireshark on the Fedora 14 client I can see responses 
being generated so I presume that they are being transmitted (especially 
as the that machine has no problems connecting to a Buffalo AP).

So it looks as though the EAPOL responses are being lost for some reason 
but having got that far I've reached something of an impasse.

Does anyone have any suggestions as to what the problem might be or what 
my next step in debugging it should be?



More information about the Hostap mailing list