WPS problems after updating hostapd

Sven Neumann s.neumann
Thu Dec 13 06:29:12 PST 2012


we are having problems to perform WPS between a Linux host running Linux
3.4.16 and hostapd 1.0 using an ath5k card and a Linux client running
Linux 3.0.4 and wpa_supplicant 1.0 using a Marvell Libertas SD8686
module. We have done WPS successfully on these devices before using
hostapd 0.7.3. But now I've tried to update hostapd and WPS stopped
working with both version 1.0 and 1.1.

I've done my experiments using hostapd_cli and wpa_cli and basically
what I tried was using the 'wps_pbc' command on both sides. I've
collected logs of this that I have attached. You will find wpa_cli.log,
which is the output of wpa_cli after using the wps_pbc command. The
second attachment is a tarball that contains debug output from hostapd
and wpa_supplicant.

It would be very helpful if someone with more clue about these things
than me could have a look at the logs and/or perhaps give me some
pointers on what I could do to shed some more light on this.


Sven Neumann
Head of RAUMFELD Software Development

www.teufel.de  www.teufelaudio.com

-------------- next part --------------
A non-text attachment was scrubbed...
Name: wpa_cli.log
Type: text/x-log
Size: 3832 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20121213/cca7f2e1/attachment.bin 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: wps-logs.tar.gz
Type: application/x-compressed-tar
Size: 12036 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20121213/cca7f2e1/attachment-0001.bin 

More information about the Hostap mailing list