mode AP kernel 2.6.31, no driver wrappers registered!: Solved

Genar Codina Reverter genarcodina
Thu Sep 17 05:20:25 PDT 2009


"Trying to set up an Atheros mini WiFi PCI in mode AP using ath5k and hostapd"

In my previous mail I have given a full description about my configuration and I commented that I could not
execute hostapd. The problem was that I tried to build "hostapd" from the source code and I made some mistakes and then
I decided to install "hostapd" using apt-get (which is a good choice). So the problem is that when I was calling "hostapd" I was
executing the "wrong" executable instead of the executable installed using apt-get.

So, the summary to made work hostapd using the ath5k module provided by the kernel 2.6.31 is:
1) load the "ath5k" module which is included in the new kernel 2.6.31 (modprobe ath5k)
2) load he "hostap" module, which is also icluded in the new kernel 2.6.31 (modprobe hostap)
3) Install the the "hostapd" utility, version 0.6.9, which I have installed via "apt-get install hostapd".
    I have used "deb sid contrib non-free main" in the configuration file
    "/etc/apt/sources.list" in order to install the latest version of hosapd; that is, 0.6.9
4) The basic configuration of the file "/etc/hostapd/hostapd.conf" is:

Notice that the driver used in configuration file is "driver=nl80211", which seems to be the suitable driver to be used
by all the "Linux mac80211 drivers" (for example the "ath5k" module has developed to be a "Linux mac80211 drivers",
like the driver "ath9k", which is suitalbe for 11n WiFi's).

In my case the information about the miniPCI Wi-Fi can be seen executing the command: lspci -vvv; that is:

00:0c.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
        Subsystem: Atheros Communications Inc. Compex Wireless 802.11 b/g  MiniPCI Adapter, Rev A1 [WLM54G]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 168 (2500ns min, 7000ns max), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 9
        Region 0: Memory at e0080000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
        Kernel driver in use: ath5k
        Kernel modules: ath5k

Note: Before loading the module "ath5k" there did not exist the line:
        Kernel driver in use: ath5k
        That is this line has appeared after executing: "modprobe ath5k"


Windows Live?: Keep your life in sync. Check it out!
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Hostap mailing list