Unable to connect using wpa_supplicant, blacklisted

Michael Kurecka wpi.hostapd
Wed Jun 17 11:35:56 PDT 2009

Thanks, that seemed to have resolved that problem but I ran into another. I
tried to attach the log but it exceeded the 25k limit but basically the
problem is that I'm getting the

WPA: 4-Way Handshake failed - pre-shared key may be incorrect

message. I'm sure the values are right so is there another reason to get
this message or is there a way to put a trace message in to print both
values for comparison?

On Wed, Jun 17, 2009 at 12:55 PM, Jouni Malinen <j at w1.fi> wrote:

> On Wed, Jun 17, 2009 at 12:36:41PM -0500, Michael Kurecka wrote:
> > I've been unable to get wpa_supplicant working and was hoping someone
> could
> > help me figure out why. It seems that the AP is being blacklisted because
> of
> > an authentication timeout, but I'm not sure why it isn't authenticating.
> The
> > wpa_supplicant is being run on the Linux OS and ARM processor with
> Madwifi
> > driver. The debug file is attached and my configuration settings are:
> It looks like you have the network interface ath0 in a bridge. In
> general, that may not be that good of an idea since IEEE 802.11 does not
> support layer 2 bridging in station mode. Anyway, if you really want to
> do this, you will need to tell wpa_supplicant about the bridge interface
> to allow it to receive EAPOL frames. You can do this by adding -b<bridge
> interface> (e.g., -bbr0) on the command line.
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at lists.shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20090617/3fcf81ac/attachment.htm 

More information about the Hostap mailing list